Troubleshooting: This order has already been renewed
Symptom
When you attempt to renew or reorder a Marketplace order, you may encounter a This order has already been renewed
error:
Cause
When you renew a MarketConnect service, the system generates a unique order number.
WHMCS's logic limits each individual Marketplace order number to one renewal in order to prevent duplicate renewals. Because of this, the system will prevent renewal if it has successfully completed the Renew Module Command against the current order number for the service.
Solution
To resolve this error, correct the service's order number:
1. Go to the Log tab in the client profile.
2. In Description, search for the service's ID (in this example, 11).
3. Note the timestamp next to the most recent Module Renewal Successful
log entry for the service.
4. In your email records, find the Order Confirmation email from WHMCS Marketplace (marketplace@whmcs.com
) that corresponds to this log entry.
The Order Confirmation email goes to the linked email address in the top-right corner at Configuration > System Settings > MarketConnect.
5. Note the order number in the email subject.
6. In WHMCS, return to the client profile's Products/Services tab and select the affected MarketConnect service record (in this example, 11).
7. Enter the order number from step 5 in Order Number.
8. Click Save Changes.
9. Click Renew for Module Commands.
Previous Article
Next Article