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Internal error occurred (Code 15). Please contact support. Errors

Symptom

When manually configuring a certificate in the Admin Area or Client Area, you see a Code 15 error:

Internal error occurred (Code 15). Please contact support.
Internal error occurred (Code 15). Please contact support.

Cause

The Certificate Signing Request (CSR) you are submitting does not contain a valid Common Name value.

For information on Common Names, see What is a Common Name (CN?).

Solution

To resolve this issue:

  1. On your server, generate a new CSR that specifies a valid Common Name. For more information, see How to Generate a Certificate Signing Request (CSR).
  2. In WHMCS, click Manually Configure Certificate. For more information, see How To Manually Configure an SSL Certificate.
  3. Submit the new CSR.